Our servers are currently experiencing difficulties.

Minor incident Server
2023-01-07 18:46 CEST · 1 day, 13 hours, 2 minutes

Updates

Resolved

We are back to normal.

January 9, 2023 · 07:49 CEST
Investigating

Our servers are currently experiencing difficulties. Your orders will take a little longer to process.

January 7, 2023 · 19:39 CEST

← Back