System is slow and unresponsive.

Major incident Google scraping API Clustering API Context API Title AI API Server
2023-01-31 23:40 CEST · 8 hours, 7 minutes

Updates

Resolved

The issue is resolved.

February 1, 2023 · 07:48 CEST
Investigating

We are experiencing some problems with our servers. Your reports may take longer to process or, in some cases, fail. We are looking into this problem and will keep you updated. All affected orders will be automatically resolved.

January 31, 2023 · 23:41 CEST

← Back