Some tool features are currently down or slow.

Major incident Keyword Insights App Google scraping API Clustering API Context API Title AI API Server
2023-11-23 19:13 CEST · 3 hours, 48 minutes

Updates

Resolved

Issues resolved.

November 23, 2023 · 23:00 CEST
Issue

Due to technical issues and increased demand, some features of our tool may experience slowdowns or be temporarily unavailable. Our developers are actively working to resolve these issues. We’ll notify you as soon as everything is back to normal. Your patience is greatly appreciated.

November 23, 2023 · 19:13 CEST

← Back