We are investigating an issue with Keyword Insights

Major incident Keyword Insights App Server
2022-02-23 21:54 CEST · 43 minutes

Updates

Resolved

Minor issue with the database. The app is working now, as usual.

February 23, 2022 · 22:37 CEST
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

February 23, 2022 · 21:55 CEST

← Back