Backend issues causing orders to fail

Major incident Keyword Insights App Google scraping API Clustering API Context API Title AI API
2022-03-20 22:16 CET · 10 hours, 17 minutes

Updates

Resolved

Issue resolved.

March 21, 2022 · 08:34 CET
Investigating

We are currently investigating an issue with our order processing system. Please hold until the issue is resolved before you place an order.

March 20, 2022 · 22:18 CET

← Back