We are investigating a problem with slow order processing.

Major incident Keyword Insights App Server
2022-03-24 16:12 CET · 5 hours, 48 minutes

Updates

Resolved

We resolved this issues. Thanks for your patience.

March 24, 2022 · 22:01 CET
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

March 24, 2022 · 16:13 CET

← Back