Keyword Clustering Module is not working

Major incident Keyword Insights App Google scraping API Clustering API Context API Title AI API Server
2022-04-13 13:38 CET · 53 minutes

Updates

Resolved

Issue resolved.

April 13, 2022 · 14:32 CET
Investigating

We have a significant bug causing our orders to have incorrect output data. We advise not to run any orders until we resolve the issue.

April 13, 2022 · 13:39 CET

← Back